Ask Your Question
0

在Windows子系统WSL上面运行playerpro的Linux版本出错

asked 2019-10-28 02:01:45 -0600

fisherw gravatar image

Windows10自带的子系统,装Ubuntu,装好playerpro的Linux版本以后,运行到create group的时候出错。

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2019-10-28 02:02:53 -0600

fisherw gravatar image

updated 2019-10-28 02:12:08 -0600

win10子系统自带的Linux不支持32位的软件,可以按照以下链接方法,添加对32位运行库的支持。当尝试通过后,就可以完整运行playerpro了。

https://github.com/Microsoft/WSL/issu...

1.先安装库

sudo apt update sudo apt install qemu-user-static sudo update-binfmts --install i386 /usr/bin/qemu-i386-static --magic '\x7fELF\x01\x01\x01\x03\x00\x00\x00\x00\x00\x00\x00\x00\x03\x00\x03\x00\x01\x00\x00\x00' --mask '\xff\xff\xff\xff\xff\xff\xff\xfc\xff\xff\xff\xff\xff\xff\xff\xff\xf8\xff\xff\xff\xff\xff\xff\xff'

2.启用

sudo dpkg --add-architecture i386 sudo apt update sudo apt install gcc:i386

3.尝试

$ file /usr/bin/gcc-5 /usr/bin/gcc-5: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.32, BuildID[sha1]=2637bb7cb85f8f12b40f03cd015d404930c3c790, stripped

$ /usr/bin/gcc-5 --version gcc-5 (Ubuntu 5.4.0-6ubuntu1~16.04.9) 5.4.0 20160609 Copyright (C) 2015 Free Software Foundation, Inc. This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

$ gcc helloworld.c -o helloworld

$ ./helloworld Hello, world!

$ file helloworld helloworld: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.32, BuildID[sha1]=3a0c7be5c6a8d45613e4ef2b7b3474df6224a5da, not stripped

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-10-28 02:01:45 -0600

Seen: 177 times

Last updated: Oct 28 '19